xable.net

Discussion Forums

You are not logged in.

#1 02-11-11 04:29

dedge_10
Member

How can I use custom DLLs with your update pack?

Hi
I want to sliptream Your XUpdatePack-SP3-v2.0.16
but with out these
KB2286198
KB2483185
KB971029   
KB2393802

do i just search for the entries  and delete them
chears
Dedge

Offline

02-11-11 04:29

Advertisement

Re: How can I use custom DLLs with your update pack?



#2 02-11-11 06:13

umapathy
Member

Re: How can I use custom DLLs with your update pack?

Dedge, just curious to know what would be the reason to skip these updates when xable is kind enough to pack all the required updates.

Offline

#3 02-11-11 07:16

dedge_10
Member

Re: How can I use custom DLLs with your update pack?

I have custom DLL's
and these updates mess my Dll's

Offline

#4 02-11-11 08:01

Darren
(aka xable)

Re: How can I use custom DLLs with your update pack?

Hi dedge, I have renamed the topic title to something more relevant.

Removing non-optional security updates is not advisable. If you want to use customised dlls you need to modify the latest versions of the DLLs (those in my update pack), them copy them to your CD after slipstreaming my update pack.

Reshacker can automate resource modifying so if a new version of a DLL is released you don't need to spend time manually modifying it.

Offline

#5 02-11-11 11:11

dedge_10
Member

Re: How can I use custom DLLs with your update pack?

I have all my Dll's etc all cab'ed up.
what i normaly do is used nlite with your update pack then after nlite as done its thing, copy over my cabs over just before i make an image of windows.
Is this correct
:-)

Offline


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 748

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xable/xable.net/forums/include/parser.php on line 821

#6 02-11-11 13:42

Darren
(aka xable)

Re: How can I use custom DLLs with your update pack?

dedge_10 wrote:

Is this correct

Impossible to say without more detail.

Offline

#7 04-11-11 01:15

dedge_10
Member

Re: How can I use custom DLLs with your update pack?

Hi darren thanks for the info on my prev post all works with my custom DLL's now,
Thought this would be the best place to post this as it sim problem.
In the past i did this in XP SP3.  intergrated WMP11, Then Intergrated IE8 with this (OnePiece IE8 WinXPSP3 v2.8.0 AddOn ENU). Then used your XUpdatePack-SP3-v1.0.32 and has always work for me.
But now when i use your latest XUpdatePack-SP3-v2.0.16 WMP11 does not work saying it is missing. and IE8 i get This tab has been recovered loop. Am i doing this wrong now with the latest update. Do i now do it different, eg Put this in first XUpdatePack-SP3-v2.0.16. Then intergrate WMP11 and OnePiece_IE8_WinXPSP3_v2.8.0_AddOn_ENU
:-)

Offline

#8 04-11-11 05:54

Darren
(aka xable)

Re: How can I use custom DLLs with your update pack?

Always slipstream update packs first, test, them make modifications.

Offline

#9 25-09-12 00:41

gsuresh2u
Member

Re: How can I use custom DLLs with your update pack?

Hi, i made some modifications in system32.dll , and converted it into system32.dl_  using dos command makecab shell32.dll
Then i replace the Original shell32.dl_ file with the modified file, but when installing i am getting Error,

Is it correct procedure ?

Last edited by gsuresh2u (25-09-12 00:42)

Offline

#10 25-09-12 09:36

Darren
(aka xable)

Re: How can I use custom DLLs with your update pack?

Hi, that sounds correct, can you successfully extract the file manually?

EXPAND.exe shell32.dl_ shell32.dll

You may need to correct the checksum before compressing with MAKECAB, that can be done with PECHKSUM;

PECHKSUM.exe -r shell32.dll

Finally are you sure you didn't break the .dll when modifying it, you could replace it on a working system to check it works, don't try it on your production system though obviously incase it doesn't boot.

To help further I'd need to know the exact error and when it occurs.

Hope that helps.

Offline

Board footer